Flashing status line in build 5.0.5005 TUI

Forum on data and disk backup and restore, partition imaging and cloning, and drive copy.
Forum rules
Discussion on the R-Drive Image software

Flashing status line in build 5.0.5005 TUI

Postby drgarner » Wed Dec 19, 2012 7:29 pm

I am a long time user of r-drive image version 4. I just started using version 5 and have noticed a minor but very annoying bug in the TUI (Text User Interface) during a restore: The status line flashes needlessly. It appears that the programmer wrote the code to refresh the status line in a fast loop with no logic to wait for a character change before re-displaying. This should be really easy to fix. The flickering/flashing of the status line (percent and pseudo bar-graph) puts a blemish on an otherwise polished product that I use on nearly 100 machines in my enterpise.

Looking forward to the next build with the bug fixed.

Thanks,
Dave G.
drgarner
 
Posts: 7
Joined: Fri Apr 01, 2011 9:42 pm

Re: Flashing status line in build 5.0.5005 TUI

Postby Alt » Thu Dec 20, 2012 10:10 am

Thank you for the response. I've passed the problem to our developers.
Alt
Site Moderator
 
Posts: 2199
Joined: Tue Nov 11, 2008 2:13 pm

Re: Flashing status line in build 5.0.5005 TUI

Postby drgarner » Thu Dec 20, 2012 1:02 pm

I made a mistake in my description of the problem. The problem is with the text mode progress bar that is displayed during a scripted backup launched from Windows. I am very sorry for this error in my original post. I tried to upload a file with this post that has a screen capture of the problem but your system gives me an error: "Could not upload attachment to ./files/2773_8748033b54af68748033b54af6c98f6eb88e0ee36957f." If you need the file I can send it via an email address you provide. Thank you for your support.
drgarner
 
Posts: 7
Joined: Fri Apr 01, 2011 9:42 pm

Re: Flashing status line in build 5.0.5005 TUI

Postby Alt » Thu Dec 20, 2012 2:38 pm

raptorbck (at) gmail (dot) com
Alt
Site Moderator
 
Posts: 2199
Joined: Tue Nov 11, 2008 2:13 pm

Re: Flashing status line in build 5.0.5005 TUI

Postby Alt » Fri Dec 28, 2012 11:57 am

We fixed this problem in this build: R-Drive Image 5.0.5006.
Alt
Site Moderator
 
Posts: 2199
Joined: Tue Nov 11, 2008 2:13 pm

Re: Flashing status line in build 5.0.5005 TUI

Postby drgarner » Fri Dec 28, 2012 9:56 pm

Awesome! Thank you very much for the superb support.
drgarner
 
Posts: 7
Joined: Fri Apr 01, 2011 9:42 pm


Return to Data Backup and Restore

Who is online

Users browsing this forum: No registered users and 2 guests