Page 1 of 1

Decision on next step

Posted: Sat Aug 12, 2017 6:56 pm
by onsan
I'm in the process of creating a disc image and I'm reviewing whether to continue or not, any advice on what you would do in this situation would be greatly appreciated.

I have a WD My Book Live 3TB that has failed, I've removed the HDD mounted it into a dual USB3 dock and am 3 days into a 41 day clone of the drive.
Prior to this I first tried Disk Internals to try and read the drive

I'm using windows 10 Pro on an Intel Core i5-6400 CPU, 64-bit OS, x64-based processor.

I first tried Linus DiskInternals Reader to copy the data, the programme read the drive as;
K: 2794.52GB Linux Swap
Linux Ext Vol 1 1.91GB
Linux Ext Vol 2 1.91GB
Linux Swap Vol 1 489MB

If I try to access these files through DI Reader I get the error;
"Can't open disk: K:
Check the disk and try again.

Thinking I had a damaged partition I then downloaded DiskInternals Partition Recovery
Using that I scanned the drive and selected “Yes”

I then tried R-linux to try and recover damaged partitions, in running “open drive files” the programme generated errors in trying to read the disk (see screenshot below).

A quick test gave the following error.

Test Option: QUICK TEST
Model Number: WDC WD30EZRS-11J99B1
Unit Serial Number: WD-WCAWZ2745213
Firmware Number: 80.00A80
Capacity: 3000.59 GB
Test Result: FAIL
Test Error Code: 06-Quick Test on drive 8 did not complete! Status code = 07 (Failed read test element), Failure Checkpoint = 105 (Unknown Test) SMART self-test did not complete on drive 8!
Test Time: 14:58:11, August 08, 2017

SMART Test result;

I have since removed and reinserted the HDD into the other dock and tried creating an image again, this time it began working and until today looked ok.
However since the early hours of this morning it began returning the Read disk XXX at position XXXXX failed after 1 attempts. The request could not be performed because of an I/O device error, again.

I'm conflicted now as to whether to continue with the disk imaging and risk the drive failing in the month it'll take to scan or to go again and try and read the disk and access whatever I can now, but knowing that I may not be able to start the image cloning again...
Most of the contents is movies and music, which although is a PITA to lose, it's not the biggest concern.
I have photos and files that I do wish to recover and although I have backed them up I'm fairly sure that there are some that aren't on the most recent backup.

Is there a way of imaging only this section of the drive? I'm thinking only if I can read the folder structure of the main partition, which I haven't been able to so far.

From what I can guess it's a bit of a gamble either way, most advice I've read suggests cloning the drive is the priority (and that seems wise) but the time it will take to do this I think increases the risk of a total failure.

What would you do?

Re: Decision on next step

Posted: Sun Aug 13, 2017 10:28 am
by Data-Medics
The drive likely has what's known as the WD Slow Responding Bug. It's a firmware malfunction common to all WD drives that develops after the drive has bad sectors. It'll only continue to get slower until it either kills the heads, or just totally stops responding.

Fortunately, it's an easy enough fix for a data recovery company. We charge a flat $450 for this type of case to patch up the firmware and copy out all the data. And given that your drive is bigger than 2Tb we'd add a $50 oversize drive charge to that. Most other honest data recovery companies pricing will be comparable to that. If you tell me where you're located perhaps I can recommend a company in your region of the world.

If the data definitely isn't worth that kind of money, and you're willing to risk losing it all, then perhaps you should try cloning using gnu ddrescue or hddsuperclone in Linux. Both are pretty good at handling bad sectors, and may be somewhat faster at cloning the data.

Re: Decision on next step

Posted: Sun Aug 13, 2017 4:49 pm
by onsan
Hi DM,
Thanks for the info, I did some reading on it and the symptoms appear to match, as well as any google diagnosis does, but I will look into it further and see if I can confirm it somehow.
I'm in Townsville, Australia, I'm not too worried for about 80% of the contents, it's mostly just videos and music, just keen to recover the photos, but if you can recommend any recovery Dr's in the area that'd be great.
Alternatively I've been exploring some threads on it and it doesn't appear to daunting if worst comes to worst and I can't find anyone nearby to recover it.
Mine is a 3.5" so it appears to be slightly easier than the 2.5" as described here; ... oblem.html

As it turns out the decision to stop was pretty much taken out of my hands as it began stumbling on bad sectors and stopped making progress, so I stopped the cloning for now.

Thanks for your reply and insight, greatly appreciated.

Re: Decision on next step

Posted: Sun Aug 13, 2017 6:16 pm
by Data-Medics
I know a guy out there in Australia who's really good at data recovery, but I can't remember what company he actually works for. I sent him a message through another forum. When he gets back to me I'll post a reference for you. He's actually a guy I consult with for difficult flash recovery cases, but I'm sure he does all the HDD stuff as well.

Re: Decision on next step

Posted: Sat Aug 19, 2017 1:55 am
by onsan
After looking into this further I tried a long shot and have had some success in recovering the files, so far at least.
With the idea that it was a slow responding error I wondered if I jumpered the pins to slow the data rate down if it would avoid triggering the fault.
Trying again, it still didn't pass the WD Lifeguard Quick Test, still didn't work on RLinux partition recovery, but did work with Easeus!
Again, so far, it is reading the files during the scan currently running and I will still need to see what I can then recover from those, but for the moment it feels like I've made some progress.

Re: Decision on next step

Posted: Tue Aug 22, 2017 2:24 am
by onsan
so a few more days in.
the easeus programme was able to recover about 50GB of photos and recovered a large portion of the video and music files it kept on stumbling on bad sectors and hanging up, but I was still missing the majority of photos.
They seem have pulled the ability to change settings on reading bad sectors, I tried the recovery twice and got to the same point so I thought I might test the water with the linux software again.
Glad I did...
I tried the partition recovery and disk internals programmes again and it still refused to recognize the drive partition in both, however after attempting to open the drive in disk internals, two drives listed as /cache and /cache1 one appeared, opening these gave access to the HDD in its full file structure.
I've been selectively triag saving the files since and while it does stumble and fail to recover some files, shutting down the drive and reloading appears to give it another go, each time it does however the cache volumes progress in sequence, I'm now at /cache4 and /cache5.
I don't really understand what is going on here, but I'm making headway and overall the disk internals software is having much more success in recovering the data.
I don't know if the jumper on the opt1 pin (switching it sata I speeds) is allowing the work around but I'm not willing to tempt trying without it until I've at least recovered as much software as possible.