Command Line error with build 6307

Disk backup and restore, partition imaging and cloning, and drive copy using R-Drive Image.
Forum rules
Discussion on the R-Drive Image software
MerleOne
Posts: 51
Joined: Fri Jan 30, 2009 12:11 pm

Command Line error with build 6307

Post by MerleOne » Wed Oct 21, 2020 3:51 pm

Hi,

I have been using build 6306 without a glitch on my Win7 Dell PC. Since build 3607, the command line backup fails at the end of the process, just before check. The script is unchanged except I change the destination :
With 6306 it was :
append /a /o -append-inc="true" -s=2 -a="E:\Backup\Alienware\R-TT\Alienware-SSD-Sandisk.rdr" -p="password removed" -r="Incr" -c=4 -u -bs -bs-size="150000" -bs-num-b="3" -bs-num-f="20" -check -log="E:\Backup\Alienware\R-TT\Scripts\Logs\"

With 6307 I had to change it into :
append /a /o -append-inc="true" -s=2 -a="E:\Backup\Alienware\R-TT\Alienware-SSD-Sandisk_20190927_082535_1.rdr" -p="password removed" -r="Incr" -c=4 -u -bs -bs-size="150000" -bs-num-b="3" -bs-num-f="20" -check -log="E:\Backup\Alienware\R-TT\Scripts\Logs\"
because it seems to use a new file naming system and it performed a full backup instead of an incremental one. And it also fails.

Is this a known issue with Win7 ?

I am now reverting to build 6306 to see if the issue remains.

Thanks !

Edited 2020-10-24 : I also got a similar error on a win10 machine, the backup using the command line exited and the log file is incomplete.

Alt
Site Moderator
Posts: 2631
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: Command Line error with build 6307

Post by Alt » Mon Oct 26, 2020 6:04 pm

I've informed our developers about the problem. Thank you for reporting!

Alt
Site Moderator
Posts: 2631
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: Command Line error with build 6307

Post by Alt » Tue Oct 27, 2020 4:31 pm

Did you try to use the old script with the new 6307 build, where the file name was Alienware-SSD-Sandisk.rdr?
If yes, did it fail, too? If yes, we'll fix this bug.

MerleOne
Posts: 51
Joined: Fri Jan 30, 2009 12:11 pm

Re: Command Line error with build 6307

Post by MerleOne » Wed Oct 28, 2020 3:30 am

Hi,
Yes, I did try to use the old script but I canceled the operation before it ended as I realized it was creating a full backup under a new filename and not an incremental one. I'll try to reinstall v6307 and perform the old script again. Still, even with the updated script, it should not fail I think.
I'll post here when done.
Sincerely,
Merle1

MerleOne
Posts: 51
Joined: Fri Jan 30, 2009 12:11 pm

Re: Command Line error with build 6307

Post by MerleOne » Wed Oct 28, 2020 1:41 pm

Alt wrote:
Tue Oct 27, 2020 4:31 pm
Did you try to use the old script with the new 6307 build, where the file name was Alienware-SSD-Sandisk.rdr?
If yes, did it fail, too? If yes, we'll fix this bug.
Hi,
I reinstalled the 6307 build, performed an incremental backup with the old script : no error ! But the incremental is a full image actually.
Then I retried with the script modified so that it's really an incremental image. Then it fails again. I will now reboot and try again.

If this persists, how to use the previous image files as base for future incremental images ?

Thanks.
Sincerely
merle1

MerleOne
Posts: 51
Joined: Fri Jan 30, 2009 12:11 pm

Re: Command Line error with build 6307

Post by MerleOne » Wed Oct 28, 2020 6:09 pm

Hi again,
I think I have narrowed down the issue, it's not a destination file name issue but rather the backup set management.
With build 6307, starting with the same set of already created image files,

- [append /a /o -append-inc="true" -s=2 -a="E:\Backup\Alienware\R-TT\Alienware-SSD-Sandisk_20190927_082535_1.rdr" -p="password" -r="Incr" -c=4 -u -bs -bs-size="150000" -bs-num-b="3" -bs-num-f="20" -check -log="E:\Backup\Alienware\R-TT\Scripts\Logs\"] fails at the end of the image step, just before verify
- [append /a /o -append-inc="true" -s=2 -a="E:\Backup\Alienware\R-TT\Alienware-SSD-Sandisk_20190927_082535_1.rdr" -p="password" -r="Full then Incr" -c=4 -u -check -log="E:\Backup\Alienware\R-TT\Scripts\Logs\"] completes normally

So it seems it is the -bs -bs-size="150000" -bs-num-b="3" -bs-num-f="20" part that causes the issue.
I'd like to mention there are already 34 .rdr files in the destination folder.

Sincerely,
Merle 1

Alt
Site Moderator
Posts: 2631
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: Command Line error with build 6307

Post by Alt » Thu Oct 29, 2020 5:59 pm

Thank you. I've passed the info to our developers.

Alt
Site Moderator
Posts: 2631
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: Command Line error with build 6307

Post by Alt » Tue Nov 10, 2020 6:19 pm

The newly released R-Drive Image 6.3.6308 should have this bug fixed.

MerleOne
Posts: 51
Joined: Fri Jan 30, 2009 12:11 pm

Re: Command Line error with build 6307

Post by MerleOne » Wed Nov 11, 2020 3:27 am

Thanks a lot, will try, with my former script if I manage to reassemble it correctly...

Edited : yes, it does work again with the -bs qualifiers. Great !
Regards,
.merle1.

Post Reply