Page 1 of 1

Strange RAID

Posted: Tue Jul 06, 2010 4:22 pm
by mboufleur

I end up with R-Studio after trying other solutions and this software may be the one that might solve my issue.

I have two identical disks that were joined into a logical disk using XP's dynamic disk feature. Each had 1.6TB and together they created a 3.2TB RAID-1 (stripe) volume. Suddenly, one of them started with the problems and here I am now.

Right now, this is the current situation at my XP Disk Manager:
I have a "unreadable" disk which should be the missing disk in that RAID.

When using R-Studio, I get the following info:
RorkeGalaxy #1SCSI - Which is the "unreadable" disk in windows
RorkeGalaxy #2SCSI - Which contains the RAID information
And strangelly, another Disk1, that holds only information about the LDM that should be on RorkeGalaxy #1SCSI. Disk1 is not a physical disk, and I guess something may have gone really bad with RorkeGalaxy #1SCSI in order to appear something like this in R-Studio.

I've tried to manually create the Virtual RAID (using RorkeGalaxy #1SCSI and RorkeGalaxy #2SCSI) and I do see some of the folders and files, but whenever I attempted to visualize something, R-Studio would tell me that the file could not be opened.
I ran the scan procedure on RorkeGalaxy #1SCSI and it was also able to find information about my previous partition (3.2TB), but I also had the same results when trying to view anything from there.

I believe there must be something wrong with LDM or MFT on the first Rorke disk, but I don't seem to know how to fix it. I believe it is necessary to perform an additional step prior to build the RAID and try to recover my content.

Does anyone know if this is doable?

Re: Strange RAID

Posted: Wed Jul 07, 2010 7:52 am
by Alt
Well, looks like something wrong with the hardware, which is worse.
How do you connect the SCSI disks to the computer? Through the RAID controller? If yes, how is it configured?
I suspect the problem is with the controller rather than with the disk.

But anyway, it's worth trying to recover the data.

Re: Strange RAID

Posted: Wed Jul 07, 2010 9:09 am
by mboufleur
The station is a HP xw8200 Workstation, and it has a LSI 53C1030 controller.

These two disks are Rorke Galaxy 8i RAIDS conected each to a LSI SCSI port from the xw8200 motherboard.

I tried to use the LSI CIMBrowser to check the SCSI and seems to be OK.
I've also talked with the guys from Rorke to check the Disks, and it also seems to be OK.

I've tried to change cables, inverse the cable connections... It did not solve the problem.

So far, it seems to be a logical error. I was hoping someone would have a clue about what it is.

Re: Strange RAID

Posted: Wed Jul 07, 2010 12:31 pm
by mboufleur

It seems I am finally able to view my previous content.
All I had to do was to enter "63" as the sector offset for Both disks when building the Virtual Block RAID.
I just don't know why it has worked... I tried this merely out of curiosity.

After being able to view some JPG and WAV files, we decided to purchase R-Studio and recover our content.
Content is being recovered as I write here.

Even so, I still would like to debug this issue.
After the recovery I will try some MFT recovery procedures and see if they work. If not, I will just erase both disks and copy the recovered data back.

Re: Strange RAID

Posted: Wed Jul 14, 2010 5:09 pm
by mboufleur
Ok, I just did it. Recovered all the content and erased both disks.

I also reformatted the System and recreated the two stripe dynamic disks (3.2TB), which are operating just fine now.

It took quite some time to recover my content, and now to reingest everything back. I was just wondering that if that was indeed a logical problem because of LDM corrupted database, a simple application that would retrieve the backup LDM database from the second disk and restore it to the first disk would solve my issue. Unfortunately, there was no information on how to do this anywhere, nor any application capable of doing this.

I've already wrote a support request for such feature in R-Studio, and hopefully this can be considered worth implementing.

Re: Strange RAID

Posted: Thu Jul 15, 2010 10:20 am
by Alt
A couple of points:
1. Stripe sets are the worst RAID layouts from the data safety point of view. Something goes wrong on one disk, and you may loose all the data on the both disks. A RAID 5 is a good trade-off between capacity, speed, data safety, and cost.
2. The first and most important rule of safe and reliable data recovery is NEVER ever just think about changing something on the original disks until all your data is recovered and checked. Or you may lose all the data for good. And even the smartest data recovery specialists may appear powerless.