Page 1 of 1

Retrieval from RAID-0 iSCSI target - all corrupt

Posted: Thu Feb 03, 2011 4:23 pm
by RichF
Hi everyone.
My scenario is as follows. I have a Synology 210j DiskStation (NAS) running two identical 80GB SATA-150 drives in RAID-0. (I know it was the wrong choice and shouldn't have been running Striped, but Mirrored, but I was tempted by extra performance and extra capacity. In any case I don't think RAID-1 would have saved me in this instance. A backup system, now that would have made life a lot better!) My client machines are a Windows 7 x64 Home and a Windows 7 x32 Basic. Most of the files are stored in Shared Folders for Photos, Music etc and these folders are all perfectly intact and functioning fine. However, there was also a 24Gb iSCSI target which was originally formatted by the Win7 x64 machine in NTFS format. I have not yet been able to ascertain if this resides on a seperate partition or within the main partition of the single Volume but have asked that question on the Synology Support Forum. The iSCSI target held all the data for the three users on the network (my family). This worked great for the last 9 months or so, but suddenly last week all the files in the iSCSI target were lost, I don't know whether lost by Windows or the Synology NAS. All that remained were three empty folders which are the user names.
I assume that the files are still present, but either have been marked as deleted by Windows, or else have simply lost their NTFS Directory Entries. Consequently I registered R-Studio and started reading the excellent manual. I have made images of both discs and am working with these. The good news is that there is nothing I have seen so far to suggest that there is any corruption or bad sectors on either of the discs. I then have mounted them in a Virtual RAID Volume Set in various ways and Scanned the Volume Set. Each disc contains 3 Partitions and some empty space and all the partitions and the empty space show as the same size and Start Position for each discs. (There is a different label on Partition 3 or one disc image compared to the other, but I am assuming this is irrelevant.) I have experimented with various ways of mounting the images or partitions into a Virtual RAID Volume Set and thought I had struck gold when I mounted both Partition3 in a Virtual Block RAID 2, selecting RAID0, 64KB Block Size, Deafult Block Order, 2 Number of Rows and Synchronise Offsets unset.
This configurations showed four Recognized Partitions, plus Extra Files. Recognized3 is 146.67GB and contains some (but not all) of the contents of the shared folder as boot records and file entries found. It even contains the file structure of "homes", then my user names, but all three folders are empty. I am able restore files from here and they are uncorrupted and open normally. Recognized2 is 709.30MB and contains nothing useful to me as only boot records are found. Recognized1 is 21.36GB and also contains nothing useful to me. But in Recognized0 21.14GB I find the directory structure and every file listed that I am looking for, plus they all look like the right file size listed. Eureka!
So I then proceeded to mark the files I wanted and then to Recover them. The process completed with no errors, and the directory structure has been preserved. The files are all of the expected size too, but when I try to open any of the files they are almost all corrupt. Very small files (eg 1kB) are fine, in fact you will not be surprised to know that the cut-off for the file size is about 64Kb. Anything smaller is fine, but anything bigger is corrupt. I assume that the Recovery process has not worked because of the Striped array.
I have looked through the help forum here and found a few related posts: Files from Raid5 all corrupted, R-Studio for RAID recovery. It seems that the Virtual RAID Volume Set has not been rebuilt quite correctly. Could anyone give me a clue as to what particular settings are causing my problems? Is it settings in the Virtual RAID Volume Set, or even in the Restore options. I'd be most grateful for some help.
Thank you.

Re: Retrieval from RAID-0 iSCSI target - all corrupt

Posted: Fri Feb 04, 2011 6:17 am
by RichF
Many thanks to the R-Studio support team for the reply earlier, suggesting that the problem most likely relates to block size. I started to look for information on the block size in iSCSI targets from Synology's forums, but decided that it may be easiest to simply place the two drives in the NAS and look at the iSCSI target there. The ideal tool to look at it seemed to be R-Studio so I fired up the programme and found that the iSCSI target was listed as a Volume. A quick scan of that Volume and the files were visible complete with their original file paths, so I crossed my fingers and started a restore. Sure enough, all the files have restored perfectly and I am very relieved.

So to rebuild the NAS with RAID-1 and implement a proper backup regime, or better two.

Re: Retrieval from RAID-0 iSCSI target - all corrupt

Posted: Fri Feb 04, 2011 8:55 am
by Alt
I'd add one thing - RAID0 is for a fast access to temporary files like swaps and so on. If you need speed and reliability, use RAID 5. A cost of an extra 80GB drive is nothing compared with the time, money, and nerves one could lost, and not always with such a good end.

Re: Retrieval from RAID-0 iSCSI target - all corrupt

Posted: Sat Feb 05, 2011 6:03 pm
by RichF
Amen to that.