RAID 5 crash, need help

Discussions on using the professional data recovery program R-STUDIO for RAID re-construction, NAS recovery, and recovery of various disk and volume managers: Windows storage spaces, Apple volumes, and Linux Logical Volume Manager.
Thornton

RAID 5 crash, need help

Post by Thornton » Thu Aug 20, 2009 9:43 pm

Hello

Ok, so my RAID 5 failed on me today.

Long story short: Intel Matrix ICH8R controller. 3 * 750 Gb in RAID 5, no problems so far, all is good.
I Then add a 4th 750Gb disk to the RAID and uses the "Add one or more member hard drives" from the modify volume menu.
The array starts migrating and everything is good. 16 hours later it is done. But i have not expanded the Volume to fit the entire array. So i use the "Utilize 100% of available array space" option from the modify volume menu.

Instantly the Intel storage manager software refreshes and now shows a 49.7 Gb Volume instead of the expexted 2 Tb (or the previous 1,36 Tb)
The server begins to slow and finally halts. Uppon reboot the RAID Bios happily reports 1 49.7 Gb RAID 5 with no errors!
The big problem here is, that the volume is now gone i windows and the only thing i can see is a 49.7 RAW partition.

So what am i suppose to do here? I tried clearing the RAID config fron the disks and creating a new RAID identically to the old (the old being the 3 disk 1.36 Tb) No luck. Tried to create a new 4 disk 2,1 Tb (as i wanted and i suppose was done since the migration had completed) - still no luck.

I have tried everything. I can without problems remove the RAID config and scan the disks with R-studio - the only problem is, that most of the files are corrupt.

The funny thing thu is that i af scan like 10% of the drive and stop it, i usually have Recognized0, 1 and 2
When opening these is don't se a identical directory og file structure. The structuce is see is correct compared to what is expected to be on the disk, byt the 3 "recongnized" don't show the same.
The 3 do share some files and folders, but what is even stranger is that files found in both recognized 1 and 2 can only be successfully recovered from "recognized1" without the file being corrupt? If i recover the same file from "recognized0" it is corrupted.

What am i doing wrong? Im an pretty sure i have the stripe size correct, but i must admit im am not sure about the order of the drives. I have tried following the page here, but when i edit/view the disks all there is at sector 0 is zeroes?

What is my next step? Is all hope lost or am i just doing something wrong?

Thanks
Peter Thornton

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: RAID 5 crash, need help

Post by Alt » Mon Aug 24, 2009 4:31 am

Online RAID expansion is one of the worst enemies of data, among partition managers and system recovery disks. NEVER ever think about doing such operations unless your data is reliably backed up.
When expanding a RAID, its controller re-distributes data over the new set of disks, overwriting the old data with the new one. If the process fails, you have part of your data written in the new manner, part in the old one, making data recovery extremely hard.

In your case it seems that the controller finished re-distributing data over the disks, so scan for Known File Types might help, if you specify the RAID parameters correctly.

Post Reply