Restoring Server Backups

A forum on data recovery using the professional data recovery software R-STUDIO.
Robertoisrad
Posts: 4
Joined: Thu Jan 30, 2014 1:25 pm

Restoring Server Backups

Post by Robertoisrad » Thu Jan 30, 2014 1:29 pm

Hi I'm having trouble restoring a backup of windows server 2012 essentials. My setup is:

1 -160gb hard drive with the operating system on it

2 - 2tb hard drives with raid 0 to hold all of my data

1 - 4tb hard drive that is only used for backing up everything

I ran into trouble when the 160gb hard drive died. I replaced the hard drive and re installed the operating system but somehow installing the new hard drive broke my raid causing me to lose all of my data. "No worries" I thought to myself I have been doing twice daily backups of everything since I put this server together.... My problem is restoring the backups. I have two backups listed in the windows backup software from the day before all of this went down, they both say completed successfully and have no errors listed. If I go to the folder I have vhdx image files of the three partitions that get backed up every day. When I go to restore one of three things happens.

1. If I try and restore the entire volume using the recovery wizard I get the error "Windows Backup cannot find a shadow copy of the backup set on the storage location"

2. If I try and restore just "files and folders" I can't expand any folders to see the files/folders. All of my folders say "Unable to browse *foldername*. Windows backup cannot find a shadow copy of the backup set on the storage location."

3. If I restart and try a recovery from the instillation disk I'm not able to see the recovery files at all.

I'm able to mount the hard drive images and two of the images work just fine but not the third (The one I really want with all of my data on it). When I mount the third it tells me the file system is RAW and would I like to format (Always chose no).

I have scanned the image file when it was mounted as RAW with R-Studio. R-Studio finds all of my files but is only able to give me back less than a third of them. Scanning the broken raid doesn't give me any files. Is there any setting or something I could do that would allow me to recover more?

If anyone could help me out I would be eternally grateful. I stand to lose a ton of data including almost all of the videos and pictures of my kids. I thought I was doing everything right but for some reason my back ups wont go....

Thank You!

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: Restoring Server Backups

Post by Alt » Fri Jan 31, 2014 8:01 am

Did you do anything with the data on the RAID0 disks? If no, I'd recommend you to create a virtual RAID0 in R-Studio and try to recover files from it. How to create RAID0 in R-Studio: Volume Sets, Stripe Sets, and Mirrors. This free program can help you to find RAIDs parameters: ReclaiMe Free RAID Recovery.

Robertoisrad
Posts: 4
Joined: Thu Jan 30, 2014 1:25 pm

Re: Restoring Server Backups

Post by Robertoisrad » Fri Jan 31, 2014 10:02 am

I haven't really done anything with the raid yet. I started adding a few files back after my initial scan showed nothing...I figured it was a lost cause, I'll stop now. I didn't know that it was possible to recreate the raid Thank you! I'll give it a try

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: Restoring Server Backups

Post by Alt » Sun Feb 02, 2014 5:41 am

I don't think it's time to give up. If not much is overwritten on the RAID disks, chances are high that you eventually got your files back.

Post Reply