R Studio doesn't reconstruct folder structure on deleted folders

A forum on data recovery using the professional data recovery software R-STUDIO.
Pin

R Studio doesn't reconstruct folder structure on deleted folders

Post by Pin » Mon Mar 02, 2020 11:46 am

Hi guys!
Recently I'm having some trouble recovering deleted files in R-Studio. Whenever I try to extract a deleted folder and its subfolders, R-Studio ignores all the folder structure (even though I mark the option "Recover folder structure" in the recover menu) and extracts all the files directly in the destination folder i selected. I even tried to mark the option "Restore from Root", but it didn't work. Can you help me ??

Alt
Site Moderator
Posts: 2631
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: R Studio doesn't reconstruct folder structure on deleted folders

Post by Alt » Mon Mar 02, 2020 3:20 pm

Can you be more specific on what you have done?

Pin

Re: R Studio doesn't reconstruct folder structure on deleted folders

Post by Pin » Tue Mar 03, 2020 8:02 am

I opened the drive and saw the folder I needed. Then I selected it and clicked "Recover Marked". The first image shows how i viewed the folder inside RStudio. The Second One shows how it was extracted (all those files were inside the three main subfolders). The third image shows the recover configurations I marked on the Recover Menu.

Image 1: https://imgur.com/dByTqsZ
Image 2: https://imgur.com/a/1HXUSLv
Image 3: https://imgur.com/a/HBHrVZw

It seems like RStudio is ignoring part of the folder structure and leaving the files on the destination folder i select.

Data-Medics
Posts: 198
Joined: Tue Oct 20, 2015 10:13 am
Location: Providence, RI USA
Contact:

Re: R Studio doesn't reconstruct folder structure on deleted folders

Post by Data-Medics » Tue Mar 03, 2020 11:28 am

I once had an odd case where this would keep happening. It seemed to be specific to the drive I was recovering. Something about the data on that drive kept causing R-Studio to glitch and pull ever sub-folder out and dump it into the root folder

Pin

Re: R Studio doesn't reconstruct folder structure on deleted folders

Post by Pin » Tue Mar 03, 2020 12:55 pm

Data-Medics wrote:
Tue Mar 03, 2020 11:28 am
I once had an odd case where this would keep happening. It seemed to be specific to the drive I was recovering. Something about the data on that drive kept causing R-Studio to glitch and pull ever sub-folder out and dump it into the root folder
Yes, that was exactly the case !! The weird think for me is that this has been happening in different situations, with different drive models

Alt
Site Moderator
Posts: 2631
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: R Studio doesn't reconstruct folder structure on deleted folders

Post by Alt » Wed Mar 04, 2020 12:37 pm

Pin wrote:
Tue Mar 03, 2020 12:55 pm
Yes, that was exactly the case !! The weird think for me is that this has been happening in different situations, with different drive models
Can you provide us with a FS snapshot to cure the problem? If yes, please go to Settings -> Main and select Debug Mode. Then, right-click the logical disk on the Device pane and select Create FS Snap Shot. Select Extended system snap shot files on the Save as type drop-down box, save the files, zip them, and send to us: raptorbck (at) gmail (dot) com. If the resulting file appears too large, PM me an I'll provide you with an ftp place to upload the file.
Those snapshots do not contain actual file content, only the info about the files and folders.
Thank you in advance.

jasonwpegg
Posts: 2
Joined: Fri May 24, 2019 3:44 pm

Re: R Studio doesn't reconstruct folder structure on deleted folders

Post by jasonwpegg » Sun Nov 22, 2020 2:19 am

I realize it's a few months later, but I was curious as to whether or not this got resolved. I'm facing the same issue, down to the selection of files within a tree and the lack of a proper tree structure after recovery (as shown in Pin's screen captures). I thought about sending debug information to Alt, but the FSS file was nearly 500MB.

Curious to hear if there was resolution. Thanks in advance!

--------------------------------------------------------

P.S. The drive I'm working on is a 250GB drive that was essentially a botched Windows 10 upgrade from Windows 7 (according to the original user). There are symbolic links between "Users" and "Documents and Settings" (as one might expect). The drive was read from a StarTech.com USB3 drive toaster. I mention all this just in case there's something else I should be trying, such as installing the drive in my recovery machine directly, rather than using a toaster. I'm running the current version (8.14.179693) of R-STUDIO.

Alt
Site Moderator
Posts: 2631
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: R Studio doesn't reconstruct folder structure on deleted folders

Post by Alt » Mon Nov 23, 2020 6:57 pm

jasonwpegg wrote:
Sun Nov 22, 2020 2:19 am
I'm facing the same issue, down to the selection of files within a tree and the lack of a proper tree structure after recovery (as shown in Pin's screen captures). I thought about sending debug information to Alt, but the FSS file was nearly 500MB.
Is our FTP an option?

jasonwpegg
Posts: 2
Joined: Fri May 24, 2019 3:44 pm

Re: R Studio doesn't reconstruct folder structure on deleted folders

Post by jasonwpegg » Tue Nov 24, 2020 6:52 pm

Absolutely, if you're open to reviewing it. (I didn't want to be presumptuous.) What's the best way to get the connection information?

Thank you!

Post Reply