Recover / Repair Corrupt Encrypted (HFS+) DMG Files

A forum on data recovery using the professional data recovery software R-STUDIO.
Posts: 1
Joined: Wed Jan 19, 2022 2:50 pm

Recover / Repair Corrupt Encrypted (HFS+) DMG Files

Post by Siggy » Wed Jan 19, 2022 3:25 pm

Hi Everyone,

I've been trying to figure out this issue for the past several months. I will keep the description as brief as I can, but if anyone thinks they need any other specific info about this issue, I can provide them in replies. Both drives here are spinning drives, not SSD's.

MacPro5,1 with the most current version of High Sierra

I had a 4TB hard drive that I was using as a manual backup for all my files. I started running out of room on it, so decided to replace it with an 8TB drive, and then repurpose the 4TB one for Steam Game files.

I put the 8TB drive into an external OWC enclosure, because it won't mount when installed inside the MacPro. I formatted the 8TB WD drive as HFS+ and manually copied the files from the 4TB to the 8TB. Everything there seemed to go ok. I opened a bunch of documents randomly throughout the 8TB drive to see if they all seemed intact. After that, I proceeded to erase the 4TB HFS+ drive and then formatted to NTFS. My plan all along was to encrypt the drive, but in hindsight, I should have done this process first, before copying the files over.

I ran the FileVault2 encryption process using the right click contextual menu. I didn't realize that this would not give me real time feedback on the encryption process, and I ended up having to use Terminal to get that info. This ended up taking several days to encrypt the whole drive. The issue now is that a bunch of the files on this drive are corrupt. Namely two encrypted DMG files that I have about 20 years worth of files inside. I know I should have had a second backup of these, but I had to use a 2TB external Seagate to backup my work iMac to send it in for repairs. I didn't realize until a while after this, that Apple decided on it's own during the encryption to convert the HFS+ format to APFS. Something I did not want to do with this drive.

Things I've tried:
- Repair with Disk Utility. Won't even mount the DMG's.
- Verify and repair with Terminal. No dice.
- Convert the DMG with several different utilities, including DMG2IMG. These would not open either.
- Ran DiskWarrior on the DMG. It acted like it might repair them, but then sat there forever not progressing.
- One tool I ran gave me a "No End of File" error. Most of the errors I get though are "No Mountable File Systems".
- I ran a bunch of demos for recovery software. I also ended up buying R-Studio. Some of the file views show the files with a green dot. But when I recover them to my HD, the same issue still persists with the files. The partition view shows two separate APFS volumes for some reason, and a scan on some of the other software labels a "Lost HFS+ Partition".

I actually haven't been able to recover a single file that was corrupt on this drive. Even the raw jpg images won't open after recovery. I have no idea what happened with this drive. As I don't remember ever disconnecting the drive nor the power going out. Maybe 65% of the drive's files are intact and then the rest just won't open at all.

I don't see any DMG or ISO files signatures showing up in the raw recovery. Do I need to create a custom search for those file types?

Any help regarding this, or other ideas would be greatly appreciated. (I should add that these DMG files were created by me using Disk Utility. They were not downloaded from the Internet.)