RAID 5 Failure & Unable to Import configuration

Discussions on using the professional data recovery program R-STUDIO for RAID re-construction, NAS recovery, and recovery of various disk and volume managers: Windows storage spaces, Apple volumes, and Linux Logical Volume Manager.
Mad Professor
Posts: 3
Joined: Thu Sep 09, 2021 2:19 pm

RAID 5 Failure & Unable to Import configuration

Post by Mad Professor » Wed Sep 15, 2021 2:10 pm

Good day all.
I am hoping that someone here has much more experience with hardware raid setups than I do.

I was running raid 5 with 8 SATA HDD's on a Fujitsu D3116C based on the LSI (ROC SAS2208) Controller.

Anyway to the point I've just lost my raid array and I am having a very hard time trying to recover it to any kind of suitable state without losing data.

The system was running Windows Server 2019 booting from a SATA SSD.
This all started as I wanted to try out Windows Server 2022, so I downloaded the ISO and made a USB install drive.
I replaced the working windows server 2019 SSD with a space SSD for a clean install of windows server 2022. But when booting the installer it would BSOD with "storport.sys" error.
After some google searching I found posts where other people issue and seemed to be related to raid cards and or configurations.
So I removed the raid controller, and the windows installer worked fine, finished installing windows server 2022 without any issues.
Shutdown the system, and refitted the raid controller, once again to be meet with the BSOD and "storport.sys" error.
Back to google and found people saying that if the drive(s) were disconnect from the controller the system would boot without and issue.

I thought I will just disconnect the drives from the raid controller, leaving the raid controller fitted, windows would then see the raid controller and install the driver(s), and I would then shutdown and reconnect the drives.

Well windows did indeed see the raid controller and install the driver(s), but after shutting down the system and reconnecting the drivers, the raid controller is no longer seeing the raid array.

Using the windows MegaRAID Storage Manager (MSM) v17.05.02.01, I can see that all of the drives are showing as Foreign / Unconfigured.

Selecting "Scan Foreign Configuration" sees the previous setup, but fails to Import.

I did find this Q&A on Broadcom's Knowledge Base: ... garaid-arr
And this guide for MegaRAID Storage Manager (MSM): ftp://tsupport:tsupport@ftp0.broadcom.c ... in_MSM.doc

I know that RAID is not a Backup, and I should of moved/copied Important data to another drive and or to the cloud, being that I was trying something new out, but I really didn't think that this would of broken the raid array.

I have since tried disconnecting all drives except drive 0, to try and force the raid controller to re-import.
With only one drive I now get "NO Foreign Configuration is found!"
And the drive status has change from "Foreign / Unconfigured" to "Unconfigured / Good".
With all drives reconnected the status has also changed from "Foreign / Unconfigured" to "Unconfigured / Good".

As I was unable to re-import a working configuration back into the raid controller I have now moved onto trying to recover data from the drives.
Searching google for raid recovery software I was not able to find much in the way of tutorials/guides and what I have found is outdated and or does not seem to work for me.

However I tried ReclaiMe Free Raid Recovery, and it has a very simple interface, and after almost two days it spat out the following;
This is a plain-text general description of the reconstructed array layout.
The array type is RAID5.
The array consists of 6 disks.

The disks are ordered as follows:
#00: Disk 0 - Serial number A1DDFKQE, \\.\PhysicalDrive0
#01: Disk 1 - Serial number A08ZFKQE, \\.\PhysicalDrive1
#02: Disk 5 - Serial number A1YFFKQE, \\.\PhysicalDrive5
#03: Disk 2 - Serial number A1GMFKQE, \\.\PhysicalDrive2
#04: Disk 4 - Serial number A2TYFKQE, \\.\PhysicalDrive4
#05: Disk 3 - Serial number A2V1FKQE, \\.\PhysicalDrive3

Block size is 64.0 KB , same as 128 sectors.
The data starts at sector (LBA) 0 (this is often called "offset" or "start offset").

Block map is as follows:

1 2 3 4 5 P
7 8 9 10 P 6
13 14 15 P 11 12
19 20 P 16 17 18
25 P 21 22 23 24
P 26 27 28 29 30

Generated by ReclaiMe Free RAID Recovery build 3457,
I must admit I was a little bit confused as the raid controller definitely had 8 HDD's connected and they were all being detected/shown in MegaRAID Storage Manager (MSM), ReclaiMe Free Raid Recovery is clearly saying that the array only had 6 HDD's, so two of the drives must not of been configured.
I thought that the RAID Array should of be made up in order from Drive 0 to Drive 7
This is how the drives were connected to the RAID Controller as listed in the MegaRAID Storage Manager (MSM) software.
Port 0 - 3 x1:0:0 90L0A1DDFKQE
Port 0 - 3 x1:0:1 61H0A08ZFKQE
Port 0 - 3 x1:0:2 90L0A1YFFKQE
Port 0 - 3 x1:0:3 90L0A1GMFKQE
Port 4 - 7 x1:0:4 90L0A2V1FKQE
Port 4 - 7 x1:0:5 90L0A2TYFKQE
Port 4 - 7 x1:0:6 61H0A076FKQE
Port 4 - 7 x1:0:7 90M0A0CZFKQE
Even with this information I could not get the raid controller to rebuild the array, So I am now going to carry on to try and recover the data via software.

It was in fact the above software that ended up pointing me to R-STUDIO for windows, So I am hoping that this software can at least help me recover some of the files.

I would be most grateful if someone can advise how to go about using R-STUDIO for windows.

Thanks in advance

Mad Professor
Posts: 3
Joined: Thu Sep 09, 2021 2:19 pm

Re: RAID 5 Failure & Unable to Import configuration

Post by Mad Professor » Sat Sep 18, 2021 7:18 am

Thank you for your reply.
I will research the provided links and documents.

Mad Professor
Posts: 3
Joined: Thu Sep 09, 2021 2:19 pm

Re: RAID 5 Failure & Unable to Import configuration

Post by Mad Professor » Sat Sep 18, 2021 1:18 pm

Can anyone here advice on what the following might mean in the log.
Basic data partition at 32768 extends beyond disk bounds.
GPT tables error 0x20304
Thanks in advance

Posts: 220
Joined: Tue Oct 20, 2015 10:13 am
Location: Providence, RI USA

Re: RAID 5 Failure & Unable to Import configuration

Post by Data-Medics » Tue Sep 21, 2021 10:33 am

It just means that the partition table, as found and as the RAID is virtually configured, would extend past the end of the array. Typically, this means your array isn't built right.

Post Reply