recovery of RAID 1+0

Discussions on using the professional data recovery program R-STUDIO for RAID re-construction, NAS recovery, and recovery of various disk and volume managers: Windows storage spaces, Apple volumes, and Linux Logical Volume Manager.
chris

recovery of RAID 1+0

Post by chris » Tue Aug 10, 2010 12:47 am

I have been using the demo version of R-Studio with hopes of buying the full download if it showed it could recover my data, but i seem to be stuck. I'm hoping someone can point me in the right direction based on what i've done...

I have a Dell Dimension E510 running Windows XP with a 2 year old Venus T4S* external enclosure with 4 500GB Samsung drives**. It’s set up with RAID 1+0.

Sat. morning, Windows reported "disk is not formatted" errors trying to access the device. I ran the RAID management software (SiI4726.exe) and it asked if I wanted to mount 2 drives. I let it. It asked to rebuild one drive. I said yes, but it wouldn’t. Powered everything down and took the opportunity to clean out dust from the enclosure and reseat the drives. Powered everything up, ran the software, and it began rebuilding a drive. Hours later, it reported it needed to rebuild another drive. Had to power down and power up again to get it to start. Eventually, all 4 drives went through some kind of rebuild. Three took hours, the final one took just a minute. At this point, the software reports everyone is healthy and up and running, but occasionaly reports 2 of the drives as New Device. Windows thinks there are 2 new volumes, but Disk Management gives an error when I run:
An unexpected error has occurred. Check the System Event Log for more information on the error. Close the Disk Management console, then restart Disk Management or restart the computer.
Eventlog has nothing.

After trying lots of things and lots of Bing searches, I downloaded a the R-Studio demo and triggered a scan. 4+ hours later, it shows 4 groupings of directories and files. 3 are called Recognized1, 2, & 3 (yellow) and the 4th is "Extra Files Found" (green).
It shows some files and directory structure with correct names, but most files are listed in the "Extra Files Found" grouping with generated, numeric names (012345678.txt, 012345678.doc, 012345679.NEF, etc.).
Previews of 99% of files are corrupted. Recovered files are corrupted.

I've set up a Virtual Volume Set and a Virtual Mirror and a scan is chugging away. If this doesn't work, i'm not sure what i'll do next. I've studied the help and several of the FAQ and forum entries, but could be missing some details. In particular, i didn't find any info specific to RAID 10.

What are my options at this point? Am i missing something simple? Do I need to seek professional help? If so, any recommendations? (preference for local to Seattle) Do I simply need to reconfigure the RAID properly and the data will appear correctly? Other ideas or options?

thanks for any info/help/advice…
chris

*Venus T4S: http://www.newegg.com/Product/Product.a ... 6817332013
**drives: SAMSUNG SpinPoint T Series HD501LJ 500GB 7200 RPM SATA 3.0Gb/s 3.5" Hard Drive -Bare Drive

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: recovery of RAID 1+0

Post by Alt » Tue Aug 10, 2010 4:47 am

I'm afraid, all data is overwritten during drive rebuilding. There some leftovers of the file system remaining, that's why R-Studio did find something, but that doesn't help much, as they're only leftovers.
Maybe, close look at the actual data by a data recovery professional could help, but I doubt it.

Post Reply