WD Studio Edition II - RAID 0

Discussions on using the professional data recovery program R-STUDIO for RAID re-construction, NAS recovery, and recovery of various disk and volume managers: Windows storage spaces, Apple volumes, and Linux Logical Volume Manager.
tombuhn
Posts: 8
Joined: Mon Aug 30, 2010 5:55 pm

WD Studio Edition II - RAID 0

Post by tombuhn » Mon Aug 30, 2010 6:03 pm

Good day!
Problem:
I need some help in reconstructing a RAID0 from a WD Studio Edition II 2TB External HD.

What I Have:
• Legal Copy of GetDataBack’s RAID Reconstructor
• Legal Copy of R-Studio
• Legal Copy of R-Drive
• A WD 2TB Studio Edition II RAID 0 External HD
• I Can supply my license number etc if needed

Problem:
The external drive initially mounted but the partition showed as RAW, I tried to image with R-Studio as it saw the EFI and HFS Partition. I got screen shots that showed the offsets of the partitions, BUT upon trying to image the external drive, or recovering the files I needed, the computer would hang or the external hard drive would lose its’ connection to the computer.
One of the drives is going bad, I cloned the bad drive and was able to get all but 2 sectors read. I tried to insert that into the external case but that didn’t work either.

It is formatted in HFS and I need the settings to enter into R-Studio and I have not been able to find the proper settings with RAID Reconstructor or with ( trial and error ) manual settings in R-Studio.

What I Have Done:
I Have done a sector by sector clone of each HD to other hard drives, I have tried every setting in R-Studio with no working results. I have spent all day trying settings in R-Studio and in RAID Reconstructor with no luck.

Settings I have noticed in R-Studio:
• 1st partition (EFI) offset is at 40 sectors
• The EFI Partition was 200 MB (409600 Sectors)
• The HFS partition offset was 200.02 MB (409640 Sectors)
• R-Studio said the main HFS partition had a 4KB (8 sector) block size

Settings I have tried in R-Studio:
  • • Set a Virtual Block RAID
    • Set RAID settings to:
    o 2 HDs
    o RAID 0
    • Dragged each cloned hard drive over to the parents window
    • Set the start sector of EACH hard drive to:
    o Tried 0 first for each HD
    o Then tried 40 for each HD
    o Then tried 20 for each HD
    o Then tried 409600 for each HD
    o Then tried 204800 for each HD
    o Then tried 204820 for each HD
     Also tried the first HD at sector 0 and the other HD at sector 1 (Then reversed them)
    o Then I tried each of those settings on just one drive while leaving the other at 0
    • Then I tried with each of the above settings different strip sizes
    o 4KB
    o 8KB
    o 16KB
    o Etc….
    • Then I tried reversing the drive order and tried all the settings again
I really need some help, I’ve been working on this all weekend about 12 hours a day between settings and scan times!
Thanks
Tom

tombuhn
Posts: 8
Joined: Mon Aug 30, 2010 5:55 pm

Re: WD Studio Edition II - RAID 0

Post by tombuhn » Mon Aug 30, 2010 7:11 pm

I swear this is a single sector stripe? How can we rebuild this in R-Studio

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: WD Studio Edition II - RAID 0

Post by Alt » Wed Sep 01, 2010 12:06 pm

Try to find the 48 2B 00 04 00 00 pattern. This is the beginning of the 2-d sector, starting from 0, of the HFS partition. You can find the first disk and offset for the RAID0.

tombuhn
Posts: 8
Joined: Mon Aug 30, 2010 5:55 pm

Re: WD Studio Edition II - RAID 0

Post by tombuhn » Sun Sep 05, 2010 3:26 pm

Well it is a single strip RAID 0 , used Runtimes RAID to create an image then used R-Studio to recover it.

NOTE: I Hope R-Studio fixes the software to allow a 1 sector block RAID 0 rebuild.

Post Reply