Recovery of Raid1

Discussions on using the professional data recovery program R-STUDIO for RAID re-construction, NAS recovery, and recovery of various disk and volume managers: Windows storage spaces, Apple volumes, and Linux Logical Volume Manager.
locka
Posts: 1
Joined: Thu Sep 30, 2010 6:26 pm

Recovery of Raid1

Post by locka » Thu Sep 30, 2010 6:59 pm

Raid 1 not working after rebuild of seprate server boot disk.

I have a server which has a number of disks in it in the following formation

2 x 500gb Samsung Sata drives raid 1 via onboard Nvdida (old data drives not currently used)
2 x 1tb Samsung Sata drives raid 1 Via MRI PCI Sata II 2 channel card running Siliconimage raid. I believe it should be hardware raid as it allows me to configure it at the bios level before windows even loads
1 x 20gb Seagate disk also the boot disk.

Now my boot disk got infect with more spyware than I care to mention and it was so bad the only course of action was to wipe it and start again. Not wishing to do this I just replaced the disk with another spare and reinstalled my server. At this point I thought everything was fine my raid disk had not been touched neither had the raid card as I had no reason to. Both disk where still physically health. However when I booted back up the server and installed software that comes with the raid. Neither came back on line properly now can not see my raid. All I get is 2tb partition being shown along with a 193gb partition. Windows just gives me 2tb + 195gb partition and suggest they both need formatting which according to the my raid manufacturer means the raid is corrupt surprise surprise. To start with there is only physically 2tb between the two disks so not sure where the 193gb comes from. Your program reports it as following

Simage 00000 #1raid(3:16) 931.5gb (correct size of the physical disk)
Volume (4eaaf40a-c9dc-11df-b73c-50....) 31.5kb 195.3gb
Partition 2 195.3gb 736.2gb
Volume (4eaaf40a-c9dc-11df-b73c-50....) 2.0tb 195.3gb

Now prior to looking at your software I did the following

Tried each disk on it's own in another pc no luck there
Tried booting just one disk on the server to see if that would come back tried this with both disks
Updated the raid software and let it rebuild my raid
Looked at more raid repair pieces of software than I care to mention most of which not fix raid 1
Ran a scan of the disk/for partitions and also files.

I really would like to get the files back and the folder structure I am currently running. I have a so much photo work on there I need back and just getting files back with a generic name would just be a disaster. Id also like to get my lightroom catalogues and xmp data back but have no idea how to find out the information need to scan for these.

Please can you tell me if you can help in away..

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: Recovery of Raid1

Post by Alt » Fri Oct 01, 2010 8:58 am

Are you sure you don't mix a RAID 0 (stripe set) with RAID 1 (mirror)? If your system shows you a volume of 2 TB (2x1TB disk), this is a RAID 0 (stripe set).

Post Reply