R-Studio 'not responding' when external drive connected

A forum on data recovery using the professional data recovery software R-STUDIO.
aneeline

R-Studio 'not responding' when external drive connected

Post by aneeline » Thu Feb 13, 2014 3:11 pm

I have a WD My Book Essential 3TB external drive which started failing last week. It still spins up, and there are no strange noises coming from it, but it failed WD's own test, showing bad sectors. A few days ago it started showing up as 'Local Disk' in My Computer, instead of 'My Book', and the capacity is no longer visible. Windows explorer stops responding when I try to interact with the drive. Also, when the drive is connected to the computer, I am unable to load web pages in Firefox, but I do not know if this is connected.

Anyway, I have now tried several types of recovery software, and they hang and go into 'Not Responding' mode as soon as the drive is connected to the computer and the program tries to access it. As a result, I cannot even start a scan of the drive. The moment I disconnect it, everything works fine again and the programs continue doing what I wanted them to do. However, since the drive is now disconnected, I cannot take further action.

I have tried to figure out what could be causing this, and have changed the USB port and the cable with no results, but I have not yet tried it on another computer, which I will do when I get access to one this weekend, if I can not find a solution before then.

I was just hoping that this is an issue someone else has come upon, and subsequently solved. Suggestions are received with thanks.

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: R-Studio 'not responding' when external drive connected

Post by Alt » Fri Feb 14, 2014 2:32 am

If connecting to another computer doesn't help, the disk surely has hardware problems. Only professional data recovery can help, your tampering with it will only deteriorate the situation.

Post Reply