Netgear Rnd4000 v1 parameter and file access

Discussions on using the professional data recovery program R-STUDIO for RAID re-construction, NAS recovery, and recovery of various disk and volume managers: Windows storage spaces, Apple volumes, and Linux Logical Volume Manager.
sefiro
Posts: 2
Joined: Tue Feb 07, 2017 4:13 pm

Netgear Rnd4000 v1 parameter and file access

Post by sefiro » Tue Feb 07, 2017 5:03 pm

Recovering old Readynas (Rnd4000-100NAS V1). Power supply failed, drives all check out (3x1T), imaged the drives as planning to use the three drives in a new ReadyNas. Installed a demo r-studio on Windows to do the above and have the three images on a 4T data drive.

The drive layouts clearly indicate V1 Rnd4000 in a raid4 configuration with drives 1&3 showing partions and drive 2 showing no partitions (per research here and elsewhere. During this Raid4 investigation, I tried scanning the individual and group of drives using block volume autodetect which clearly did not return the data - but only the system positions (help files, Sql an etc). Used a variety of other data/nas tools to see if they could see into the data partition - with many showing text, images, movies and music. Most show as recoverable but clearly a number (5%?) Are striped as only the initial part of the file is available.

Tried using Reclaime to get parameters but it kept giving a maximum block size reached error message. Tried some other NAS recovery tools to see what if any parameters they could come up with. One came up with left-symmetric, 512 byte block and simple image of data layout that matched what I had expected to see fur this V1 Nas.

I put the parameters in r-studio and ran a scan - low and behold - it came up with the same general visual results in the scan-information window. Opening a couple of the individual scan panes - I see lists of files add I would expect. However, when I go to open the drive by file type - I get a message "the selected system does not contain any supported file system or the file system is corrupted. Select the Scan command. . . "

What am I missing?
- incorrect parameters? Does someone have better fit this old nas?
- I suspect the file system is inside the sql database, but shouldn't r-studio have done ability to recover the file - when it can be seen in the scan-information individual pane?

sefiro
Posts: 2
Joined: Tue Feb 07, 2017 4:13 pm

Re: Better Rnd4000 v1 parameter and file access

Post by sefiro » Tue Feb 07, 2017 5:51 pm

(Board op: please change title from 'Better' to 'Netgear')

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: Netgear Rnd4000 v1 parameter and file access

Post by Alt » Wed Feb 08, 2017 9:05 am

I think the parameters are wrong. I think this article can help to find them manually: Finding RAID parameters.

Post Reply