R-Studio - issues with automatic recognition of new USB

A forum on data recovery using the professional data recovery software R-STUDIO.
Peter
Posts: 13
Joined: Wed Apr 15, 2015 10:41 am

R-Studio - issues with automatic recognition of new USB

Post by Peter » Thu Sep 07, 2017 4:21 pm

in version R-Studio 8.3.167546 a new feature was added - automatic scan for newly connected USB devices.

It creates a problem with USB devices when we try to change the device properties (for example switch from "easy removal" to "high performance" mode), or to eject the device - such changes require windows reboot or device physical re-connect if R-Studio is running.

Apparently, R-Studio opens a handle for each device in the list, and do not close them even if device is not used. This prevents changes to device mode or ejecting of removable media as long as R-Studio is running.
This doesn't happen with other utilities like WinHex or UFS-Explorer.

proposed solution
1. do not keep device handle open if that device is not used.
2. disable auto-scan

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: R-Studio - issues with automatic recognition of new USB

Post by Alt » Fri Sep 08, 2017 6:37 am

I've passed the problems to our developers.

Data-Medics
Posts: 146
Joined: Tue Oct 20, 2015 10:13 am
Location: Providence, RI USA
Contact:

Re: R-Studio - issues with automatic recognition of new USB

Post by Data-Medics » Fri Sep 08, 2017 2:25 pm

This would explain some of the issues I've been having with ejecting external drives lately. I hope they get it fixed quickly.

Post Reply