R-Studio 9.2.191166 - Problem with QNAP .@__thumb directories

A forum on data recovery using the professional data recovery software R-STUDIO.
Webglider
Posts: 9
Joined: Thu Jul 20, 2023 12:54 pm

R-Studio 9.2.191166 - Problem with QNAP .@__thumb directories

Post by Webglider » Thu Jul 20, 2023 1:08 pm

Hi All,
Newbie to R-Studio, and I'm probably doing something wrong, so please excuse my ignorance...

I've recently had a Qnap NAS hardware (not discs) fail. I'm using R-Studio to recover select files.
One set of files I'm trying to restore is my Plex library.

I've found all the files and they are all showing Good (Existing file) Recovery chances.

My problem:
When I select the directory structure to recover, it seems to get hung up on the first directory which contains a directory called : ".@__thumb"

In the Log I get a repeating message:
"Recovering file Z:/Plex/Films/.@__thumb failed. The system cannot find the specified file"

When I click skip file, the recovery stops

I did try finding explicit file types such as .ts; mp4 and so on, and this didn't help.

I'm obviously missing something, so any advice, guidance (hopefully not too much chastisement) would be appreciated.

Thanks in advance, and do let me know if theirs some material information I've not provided.

Windows 11
R-Studio 9.2.191166
FileSystem Type Ext4
Was part of a RAID 1 set, if that makes any difference.
Recovery Source: WD Plus 10TB hard drive connected via a Sabrent external enclosure
Recovery Target: Qnap TS-464-8g RAID 5 (set of 4 10TB WD Red Plus drives) mapped as network drive
Original (Now Broken and completely unsable) NAS Qnap NAS TS-453be

Alt
Site Moderator
Posts: 3170
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: R-Studio 9.2.191166 - Problem with QNAP .@__thumb directories

Post by Alt » Thu Jul 20, 2023 3:40 pm

What happens when you exclude from recovery the folder that contains .@__thumb?

Webglider
Posts: 9
Joined: Thu Jul 20, 2023 12:54 pm

Re: R-Studio 9.2.191166 - Problem with QNAP .@__thumb directories

Post by Webglider » Thu Jul 20, 2023 3:49 pm

Hi,
When I manually exclude the .@__thumb directory from the list of files to be recovered, it runs through ok.
It's just that there's a lot of them nested in the QNAP (Plex library structure), and I've got about 1500+ to try and recover, so manually going in, selecting the .@ to remove/exclude is taking a lot of time :-S

Thank you for the time to consider and reply.

Alt
Site Moderator
Posts: 3170
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: R-Studio 9.2.191166 - Problem with QNAP .@__thumb directories

Post by Alt » Thu Jul 20, 2023 4:23 pm

Can you try to recover several files that have /.@__thumb in their path to a Windows folder? Not many, just several. I'm trying to understand what's wrong with this path.

Webglider
Posts: 9
Joined: Thu Jul 20, 2023 12:54 pm

Re: R-Studio 9.2.191166 - Problem with QNAP .@__thumb directories

Post by Webglider » Thu Jul 20, 2023 5:05 pm

Hi,
One of more .@ folders in the selected recovery list on the source disc, and it always the first one which fails and gets stuck retrying.

Webglider
Posts: 9
Joined: Thu Jul 20, 2023 12:54 pm

Re: R-Studio 9.2.191166 - Problem with QNAP .@__thumb directories

Post by Webglider » Thu Jul 20, 2023 5:12 pm

Log file and screenshot
Here two .@ directories were selected and it got stuck on first.

PS> Don't judge the films - the kids have a say in what is recorded.
You do not have the required permissions to view the files attached to this post.

Alt
Site Moderator
Posts: 3170
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: R-Studio 9.2.191166 - Problem with QNAP .@__thumb directories

Post by Alt » Thu Jul 20, 2023 5:21 pm

Is the Z: a network folder? If yes, please recover 1 or 2 files to a local disk, like D:.

Webglider
Posts: 9
Joined: Thu Jul 20, 2023 12:54 pm

Re: R-Studio 9.2.191166 - Problem with QNAP .@__thumb directories

Post by Webglider » Thu Jul 20, 2023 5:28 pm

Yes Z is a network drive onto the new QNAP server.

Interesting that doing it to a local SSD works.

I have full admin write permissions to the Z: drive, so I'm not sure why it objects to that folder.

The challenge I have doing locally is that I don't have enough local disk to do this recover to.

Webglider
Posts: 9
Joined: Thu Jul 20, 2023 12:54 pm

Re: R-Studio 9.2.191166 - Problem with QNAP .@__thumb directories

Post by Webglider » Thu Jul 20, 2023 5:32 pm

If it helps, the QNAP 'uname -a'

Linux NS464 5.10.60-qnap #1 SMP Thu Jun 29 02:17:27 CST 2023 x86_64 GNU/Linux

The user I'm connecting the network drive as is the admin user which I setup when configuring the QNAP NAS.

Webglider
Posts: 9
Joined: Thu Jul 20, 2023 12:54 pm

Re: R-Studio 9.2.191166 - Problem with QNAP .@__thumb directories

Post by Webglider » Thu Jul 20, 2023 5:36 pm

For reference...

He is an example to the E: drive, a local SSD.

Also shown is a write to the Z: drive - a network disk, but with the .@ source directory deselected.
You do not have the required permissions to view the files attached to this post.

Post Reply