Raid 0 Recovery deleted array and rebuild...

Discussions on using the professional data recovery program R-STUDIO for RAID re-construction, NAS recovery, and recovery of various disk and volume managers: Windows storage spaces, Apple volumes, and Linux Logical Volume Manager.
teaco
Posts: 4
Joined: Fri Mar 25, 2011 1:18 pm

Raid 0 Recovery deleted array and rebuild...

Post by teaco » Fri Mar 25, 2011 1:56 pm

Hello all,

i'm currently demo R-Studios right now and have a few questions

before i start. here are my problem or issue i'm currently going through.

i have 2 750GB hard drives RAID 0 using Intel ICH9R, and i believe the default RAID strip size is 128kb
i accidently deleted the wrong RAID array and thought i would be able to get the files back if i RAID the 2 hard drives(did not format the drive), but man was i wrong! from what i've been told i'm SOL.
The volume is NTFS
i have check raid recovery presentation and finding RAID parameters on r-studios website, but i'm still confused as to what offset means http://www.r-tt.com/Articles/RAID_Recov ... AID5-2.png

I'm assuming it's raid offset, using the hex view i can only see one drive that would show me the MBR Patterns which starts at sector 0, the other hard drive doesn't show me where the MBR starts and it's not in sector 0, but i'm assuming that i have over written the MBR when i created the new array.

also is blocksize = strip size?
when i do a scan and preview the pictures the pictures are out of order

i'm not sure what else i can try. could it be just the offset settings are what i'm missing? and if so how can i find it? also i had one big partation file on my raid 0
i have also done some searchs on the forums and couldn't find much info

hope to hear back from anyone on here!

teaco
Posts: 4
Joined: Fri Mar 25, 2011 1:18 pm

Re: Raid 0 Recovery deleted array and rebuild...

Post by teaco » Fri Mar 25, 2011 5:26 pm

i have another question.

is it possible when raid drives are configured you could have one drive offset say 63 sector and the 2nd drive could be at zero?

i think what i'll be doing over this weekend will be to create 3 scenarios. build a raid 0 with 2 hard drive. build raid 0 hard drive and delete the raid, and build the raid 0 delete and rebuild a raid 0 over it. then analyze each scenarios see what the has been changed within the hard drive.

as well find out how the offset are changed. i will post once i find the findings.

teaco
Posts: 4
Joined: Fri Mar 25, 2011 1:18 pm

Re: Raid 0 Recovery deleted array and rebuild...

Post by teaco » Wed Mar 30, 2011 4:44 pm

hello again.

I'd created a raid 0 128kb strip size drive 2x750GB drive using intel ich9r.
format in windows 7, and put in about 40GB of data.
disabled the raid in the bios and when i try and create a virtual raid and preview the photos it still doesn't look correct

how do i determine where the offset is?

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: Raid 0 Recovery deleted array and rebuild...

Post by Alt » Thu Mar 31, 2011 3:31 am

When you formatted you array in Windows 7, did you initialize the volume as a dynamic or basic disk?

teaco
Posts: 4
Joined: Fri Mar 25, 2011 1:18 pm

Re: Raid 0 Recovery deleted array and rebuild...

Post by teaco » Sat Apr 02, 2011 3:03 am

Alt wrote:When you formatted you array in Windows 7, did you initialize the volume as a dynamic or basic disk?
i'd used basic.

Post Reply