Unable to recover QNAP TS211 RAID1

Discussions on using the professional data recovery program R-STUDIO for RAID re-construction, NAS recovery, and recovery of various disk and volume managers: Windows storage spaces, Apple volumes, and Linux Logical Volume Manager.
Sudds

Unable to recover QNAP TS211 RAID1

Post by Sudds » Wed Mar 20, 2013 2:58 pm

Hi there. I purchased your software on recommendation from QNAP in regards to recovering the data from a NAS that died. The actual NAS died, as opposed to the data on the two disks. It was configured as a RAID1 mirror.
I've consulted your FAQs and other posts on this website, but was unable to locate anyone who had a similar issue to me.
I can see both disks perfectly in your viewer (after attaching them to a pc) and after enumeration I can browse to the files perfectly.
None are highlight in red or orange indicating any issues on either of the disks.
I can recover the files, however upon trying to access any of them (word, excel, avi, mp3 etc) I get 'the file could not be opened/recognised'.
The filesizes all look approximately accurate and are not zero.
A preview of the file always indicates the very first block in red, but no other issues.

What would you suggest I do to recover these files? I find it hard to believe that every single file has an identical corruption and that every file on a seemingly redundant pair cannot be recovered.

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: Unable to recover QNAP TS211 RAID1

Post by Alt » Thu Mar 21, 2013 4:15 am

Did you create a virtual mirror or did you recover files from one single drive from that pair?

Sudds

Re: Unable to recover QNAP TS211 RAID1

Post by Sudds » Thu Mar 21, 2013 5:54 am

I tried both methods.
I scanned both individual disks, then tried a recovery.
I then tried creating a Virtual mirror.
It created a volume, but wasn't sure it had created it correctly.
The two disks were 450GB each, but the virtual mirror reported a size of 900GB. In RAID1 I would expect a 450GB size.
I could not open the mirror volume.

Sudds

Re: Unable to recover QNAP TS211 RAID1

Post by Sudds » Thu Mar 21, 2013 9:29 am

I tried initially to recover the files directly from a single drive, however that gave the problem shown in my earlier post.
I then created a 'virtual mirror' using your application. I was suspect however on whether I carried it out correctly.
My two drives had volume sizes of 450GB, I would have expected the Virtual mirror to report a RAID volume of 450GB, but instead in was 900GB, suggesting it was now a RAID0 which is incorrect.
I could not open the Virtual mirror volume.
What would you recommend?

Post Reply