RAID 6 recovery scan seems to hang at 99%

Discussions on using the professional data recovery program R-STUDIO for RAID re-construction, NAS recovery, and recovery of various disk and volume managers: Windows storage spaces, Apple volumes, and Linux Logical Volume Manager.
SPYDER
Posts: 2
Joined: Mon Feb 16, 2015 9:13 pm

RAID 6 recovery scan seems to hang at 99%

Post by SPYDER » Mon Feb 16, 2015 9:41 pm

I am trying to perform recovery of a 10.7 TB RAID 6 volume from a QNAP file server in another Windows 7 machine. I have built the virtual RAID and the scan seemed to be doing just fine and was chugging along for about 1d18h when I first noticed the "time remaining" kept getting longer, but it was consistently counting down. It got to the last block, 99% complete and a minute remaining and then did something weird - it went to 30% complete and like 8 days remaining...but it seemed to chug pretty quickly (w/in 10 minutes) back to 99%, but it's been pretty much stuck at 4 minutes and some seconds remaining for the last 8+ hours. Any thoughts?

I picked RAID6 / Reed-Solomon, but it was a SWAG (I know it's a RAID 6 volume, but not sure which schema they use)

I am using R-Studio 7.6.156433 on a Windows 7 Dual Xeon machine w/ 4GB of memory and a 3ware 9550SX-8 controller.

NOTE: I never saw Partition 1 show up under the virtual RAID in the drive pain as described/shown in step 3 from http://www.r-tt.com/Articles/RAID_Recov ... ndex.shtml
You do not have the required permissions to view the files attached to this post.

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: RAID 6 recovery scan seems to hang at 99%

Post by Alt » Tue Feb 17, 2015 10:01 am

Actually, you may stop the scan. It may stop for a some time, and I advise you to save the scan info immediately after stop. 99% is more than enough to find out the data on the disk.
But looks like that something wrong with the RAID parameters.

Corsari
Posts: 131
Joined: Wed Aug 14, 2013 4:18 am

Re: RAID 6 recovery scan seems to hang at 99%

Post by Corsari » Wed Feb 18, 2015 3:45 pm

Hello SPYDER

have you solved the issue?

Cor
Robert
Technical Manager @ Recupero Dati RAID FAsTec (Italy)

USEFUL RULES and GUIDELINES
1) What to check BEFORE begin a disk image/clone process [link]
2) Disks that are too slow while imaging/cloning them [link]
3) All my posts on this forum [link]

SPYDER
Posts: 2
Joined: Mon Feb 16, 2015 9:13 pm

Re: RAID 6 recovery scan seems to hang at 99%

Post by SPYDER » Wed Feb 18, 2015 5:17 pm

After about 18 hours at 99% it completed successfully. I think the issue could be do to low (4GB) of RAM on the system. I have ordered more because I'm having issues loading the scan data now...

Corsari
Posts: 131
Joined: Wed Aug 14, 2013 4:18 am

Re: RAID 6 recovery scan seems to hang at 99%

Post by Corsari » Wed Feb 18, 2015 5:33 pm

Have you cloned the single original drives?

Read: have you set on the security side your valuable data?

One RAID 6 fails because 3 (not 2) drives are in trouble and you are stressing them so much.

Please find my others posts with best practices on this forum before to proceed.
Robert
Technical Manager @ Recupero Dati RAID FAsTec (Italy)

USEFUL RULES and GUIDELINES
1) What to check BEFORE begin a disk image/clone process [link]
2) Disks that are too slow while imaging/cloning them [link]
3) All my posts on this forum [link]

Post Reply