"Skip Files with bad sectors"

A forum on data recovery using the professional data recovery software R-STUDIO.
moses
Posts: 4
Joined: Sat Apr 09, 2016 7:49 am

"Skip Files with bad sectors"

Post by moses » Sat Apr 09, 2016 7:54 am

Hello.

I just installed the eval-version of R-Studio. The disk to recover does have bad sectors. In order to prevent R-Studio to crash, "Skip Files with bad sectors" was selected.

After beeing able to recover many files, the popup "Files with bad sectors" is shown. Now, whatever selection is made (e.g. mark, or Cancel), the recover operation is aborted and the following messages are written to the Log:
"Read disk at position 12345678 failed after 2 attemps. Illegal seek"

After this message, the partially damaged disk does disappear from /dev and R-Studio has to be restarted.



- How can files which are related to bad sectors reliable be excluded from restore-attemps?

- Is there a way to have R-Studio listed all files which are related to bad sectors?


You help is appreciated. Thank you! Moses

Alt
Site Moderator
Posts: 2271
Joined: Tue Nov 11, 2008 2:13 pm
Contact:

Re: "Skip Files with bad sectors"

Post by Alt » Mon Apr 11, 2016 6:54 am

First, go to the Tools -> Settings -> Bad sectors tab and set Default read attempt to 0.
If that doesn't help, there's hardware problems with the disk hardware that crashes the system, and not R-Studio.
Another way is to create a disk image, and try to recovery files from it.

Data-Medics
Posts: 148
Joined: Tue Oct 20, 2015 10:13 am
Location: Providence, RI USA
Contact:

Re: "Skip Files with bad sectors"

Post by Data-Medics » Tue Apr 12, 2016 4:38 pm

It's usually best to clone the disk that has the bad sectors first using a tool like ddrescue in linux. Unfortunately any tool that runs in Windows will have limitations with handling bad sectors, it's just a Windows factor. Then run R-Studio against the clone and you're good to go.

moses
Posts: 4
Joined: Sat Apr 09, 2016 7:49 am

Re: "Skip Files with bad sectors"

Post by moses » Wed Apr 13, 2016 2:06 pm

Alt wrote:First, go to the Tools -> Settings -> Bad sectors tab and set Default read attempt to 0.
If that doesn't help, there's hardware problems with the disk hardware that crashes the system, and not R-Studio.
Another way is to create a disk image, and try to recovery files from it.
Thank you Alt! I am trying to follow your advice but after changing the value to 0 and pressing either "OK", "Apply" or "Set for all drives"
O is immediately beeing replaced by 1. With the up- and down-arrows, O is not even suggested (using R-Studio for Linux 3.9)....


Regards, Moses

Guest

Re: "Skip Files with bad sectors"

Post by Guest » Sat Apr 30, 2016 8:18 am

Data-Medics wrote:It's usually best to clone the disk that has the bad sectors first using a tool like ddrescue in linux. Unfortunately any tool that runs in Windows will have limitations with handling bad sectors, it's just a Windows factor. Then run R-Studio against the clone and you're good to go.
Thank you very much for this helpful feedback! Great tool!

Moses

PS
By the way: I tried the latest Windows-version of R-Studio: It's not possible as well to set the "Default read attempt to 0".
Is this possible or am I doing something wrong??

moses
Posts: 4
Joined: Sat Apr 09, 2016 7:49 am

Re: "Skip Files with bad sectors"

Post by moses » Sat Apr 30, 2016 8:20 am

Data-Medics wrote:It's usually best to clone the disk that has the bad sectors first using a tool like ddrescue in linux. Unfortunately any tool that runs in Windows will have limitations with handling bad sectors, it's just a Windows factor. Then run R-Studio against the clone and you're good to go.
Thank you very much for this helpful feedback! Great tool!

Moses

PS
By the way: I tried the latest Windows-version of R-Studio: It's not possible as well to set the "Default read attempt to 0".
Is this possible or am I doing something wrong??

RForce
Posts: 31
Joined: Wed Jul 09, 2014 9:05 am

Re: "Skip Files with bad sectors"

Post by RForce » Tue May 10, 2016 1:24 pm

moses wrote:PS
By the way: I tried the latest Windows-version of R-Studio: It's not possible as well to set the "Default read attempt to 0".
Is this possible or am I doing something wrong??
If you read a sector 0 times, you are not reading it at all.

Data-Medics
Posts: 148
Joined: Tue Oct 20, 2015 10:13 am
Location: Providence, RI USA
Contact:

Re: "Skip Files with bad sectors"

Post by Data-Medics » Tue Jun 14, 2016 10:47 am

RForce wrote:
moses wrote:PS
By the way: I tried the latest Windows-version of R-Studio: It's not possible as well to set the "Default read attempt to 0".
Is this possible or am I doing something wrong??
If you read a sector 0 times, you are not reading it at all.
HAHA, took the words right out of my mouth.

Post Reply